make: *** [out/target/common/obj/JAVA_LIBRARIES/android_stubs_current_intermediates/classes.jar] error 41

안드로이드 코드를 빌드하던 도중 다음과 같은 오류를 맞닥트리는 경우가 있습니다.


Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
2 errors
6 warnings
make: *** [out/target/common/obj/JAVA_LIBRARIES/android_stubs_current_intermediates/classes.jar] 오류 41
make: *** 끝나지 않은 작업을 기다리고 있습니다....


이 경우 자신의 컴퓨터 환경이 다음에 해당되는지 확인합니다.


1.자신이 Build 하는 JDK의 버전이 해당 안드로이드 버전에 맞는지 확인합니다.

(GingerBread에서 Kitkat 사이에 해당되는 버전은 JDK 6을, lollipop 이후의 버전은 JDK 7을 사용해야 합니다.)


2. 컴파일 옵션을 사용하였을 경우 컴파일 도중 오작동으로 인해 위와 같은 오류가 발생하는 경우가 있습니다. 이 경우 컴파일 시간이 느려지는 것을 감수하고 옵션 없이 컴파일을 수행합니다.


$ make


만약 다음 과정을 수행해도 같은 오류가 발생시 컴파일을 처음부터 다시 수행해야 합니다.


$ make clean

$ make